* remove more unneeded files from the sourcedist tgz
[citadel.git] / webcit / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12 DESTDIR=$(CURDIR)/debian/citadel-webcit
13
14 EXTRA_ARGS=
15 PROFILE_ARGS=
16 #to enable debugging: export DEB_BUILD_OPTIONS="debug profiling"
17 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
18         PROFILE_ARGS= --with-gprof
19 endif
20 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
21         CFLAGS += -O0 -ggdb -rdynamic -MD -MP 
22         LDFLAGS += -pg 
23         EXTRA_ARGS =  --with-backtrace
24 else
25         CFLAGS += -O2
26 endif
27
28 configure: configure-stamp
29 configure-stamp:
30         dh_testdir
31         CFLAGS="$(CFLAGS)" ./configure \
32                 --host=$(DEB_HOST_GNU_TYPE) \
33                 --build=$(DEB_BUILD_GNU_TYPE) \
34                 --prefix=/usr/sbin/ \
35                 --with-wwwdir=/usr/share/citadel-webcit \
36                 --with-localedir=/usr/share/ \
37                 --with-editordir=/usr/share/tinymce/www \
38                 --with-rundir=/var/run/citadel \
39                 --with-ical --with-db --with-ldap \
40                 --with-ssldir=/etc/ssl/webcit/ \
41                 --with-zlib --with-ssl --with-libiconf \
42                 --with-newt --with-included-gettext \
43                 --with-datadir=/var/run/citadel \
44                 --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
45
46         touch configure-stamp
47
48
49 build: build-stamp
50
51 build-stamp: configure-stamp 
52         dh_testdir
53
54 # Add here commands to compile the package.
55         $(MAKE)
56 #docbook-to-man debian/webcit.sgml > webcit.1
57
58         touch build-stamp
59
60 clean:
61         dh_testdir
62         dh_testroot
63         rm -f build-stamp configure-stamp
64
65 # Add here commands to clean up after the build process.
66         -$(MAKE) clean
67
68         dh_clean 
69
70 install: build
71         dh_testdir
72         dh_testroot
73         dh_clean -k 
74         dh_installdirs
75         $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
76 #       mkdir -p $(DESTDIR)/etc/citadel; cp webcit.conf $(DESTDIR)/etc/citadel/
77
78
79
80 # Build architecture-independent files here.
81 binary-indep: build install
82 # We have nothing to do by default.
83
84 # Build architecture-dependent files here.
85 binary-arch: build install
86         dh_testdir
87         dh_testroot
88         dh_installchangelogs
89         dh_installdocs
90         dh_installexamples
91         dh_install
92 #       dh_installmenu
93         dh_installdebconf       
94 #       dh_installlogrotate
95 #       dh_installemacsen
96 #       dh_installpam
97 #       dh_installmime
98         dh_installinit --name=webcit
99 #       dh_installcron
100 #       dh_installinfo
101         dh_installman
102         dh_link
103         dh_strip
104         dh_compress
105         dh_fixperms
106 #       dh_perl
107 #       dh_python
108 #       dh_makeshlibs
109         dh_installdeb
110         dh_shlibdeps
111         dh_gencontrol
112         dh_md5sums
113         dh_builddeb
114
115 binary: binary-indep binary-arch
116 .PHONY: build clean binary-indep binary-arch binary install configure