* move to config-header similar to citserver.
[citadel.git] / webcit / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12 DESTDIR=$(CURDIR)/debian/citadel-webcit
13
14 EXTRA_ARGS=
15 PROFILE_ARGS=
16 #to enable debugging: export DEB_BUILD_OPTIONS="debug profiling"
17 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
18         PROFILE_ARGS= --with-gprof
19 endif
20 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
21         CFLAGS += -O0 -ggdb -rdynamic -MD -MP 
22         LDFLAGS += -pg 
23         EXTRA_ARGS =  --with-backtrace
24 else
25         CFLAGS += -O2
26 endif
27
28 configure: configure-stamp
29 configure-stamp:
30         dh_testdir
31         CFLAGS="$(CFLAGS)" ./configure \
32                 --host=$(DEB_HOST_GNU_TYPE) \
33                 --build=$(DEB_BUILD_GNU_TYPE) \
34                 --prefix=/usr/sbin/ \
35                 --with-wwwdir=/usr/share/citadel-webcit \
36                 --with-localedir=/usr/share/ \
37                 --with-editordir=/usr/share/tinymce/www \
38                 --with-rundir=/var/run/citadel \
39                 --with-ical --with-db --with-ldap \
40                 --with-ssldir=/etc/ssl/webcit/ \
41                 --with-zlib --with-ssl --with-libiconf \
42                 --with-newt --with-included-gettext \
43                 --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
44
45         touch configure-stamp
46
47
48 build: build-stamp
49
50 build-stamp: configure-stamp 
51         dh_testdir
52
53 # Add here commands to compile the package.
54         $(MAKE)
55 #docbook-to-man debian/webcit.sgml > webcit.1
56
57         touch build-stamp
58
59 clean:
60         dh_testdir
61         dh_testroot
62         rm -f build-stamp configure-stamp
63
64 # Add here commands to clean up after the build process.
65         -$(MAKE) clean
66
67         dh_clean 
68
69 install: build
70         dh_testdir
71         dh_testroot
72         dh_clean -k 
73         dh_installdirs
74         $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
75 #       mkdir -p $(DESTDIR)/etc/citadel; cp webcit.conf $(DESTDIR)/etc/citadel/
76
77
78
79 # Build architecture-independent files here.
80 binary-indep: build install
81 # We have nothing to do by default.
82
83 # Build architecture-dependent files here.
84 binary-arch: build install
85         dh_testdir
86         dh_testroot
87 #       dh_installchangelogs ChangeLog
88         dh_installdocs
89         dh_installexamples
90         dh_install
91 #       dh_installmenu
92         dh_installdebconf       
93 #       dh_installlogrotate
94 #       dh_installemacsen
95 #       dh_installpam
96 #       dh_installmime
97         dh_installinit --name=webcit
98 #       dh_installcron
99 #       dh_installinfo
100         dh_installman
101         dh_link
102         dh_strip
103         dh_compress
104         dh_fixperms
105 #       dh_perl
106 #       dh_python
107 #       dh_makeshlibs
108         dh_installdeb
109         dh_shlibdeps
110         dh_gencontrol
111         dh_md5sums
112         dh_builddeb
113
114 binary: binary-indep binary-arch
115 .PHONY: build clean binary-indep binary-arch binary install configure