* fixed debian build
[citadel.git] / webcit / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12
13
14
15 CFLAGS = -Wall -g -ggdb
16
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18         CFLAGS += -O0
19 else
20         CFLAGS += -O0 -ggdb
21 endif
22
23 configure: configure-stamp
24 configure-stamp:
25         dh_testdir
26         rm -rf $(CURDIR)/debian/webcit $(CURDIR)/debian/citadel-webcit $(CURDIR)/debian/citadel-webcit-apache
27         CFLAGS="$(CFLAGS)" ./configure \
28                 --host=$(DEB_HOST_GNU_TYPE) \
29                 --build=$(DEB_BUILD_GNU_TYPE) \
30                 --prefix=/usr \
31                 --with-webcit-dir=/usr \
32                 --with-sysconfdir=/etc/citadel \
33                 --with-spooldir=/var/spool/citadel \
34                 --with-staticdir=/usr/share/doc/citadel-webcit/examples \
35                 --with-rundir=/var/run/citadel \
36                 --with-ical --with-db --with-ldap --with-zlib --with-ssl --with-libiconf --with-newt --with-included-gettext
37
38         touch configure-stamp
39
40
41 build: build-stamp
42
43 build-stamp: configure-stamp 
44         dh_testdir
45
46         # Add here commands to compile the package.
47         $(MAKE)
48         #docbook-to-man debian/webcit.sgml > webcit.1
49
50         touch build-stamp
51
52 clean:
53         dh_testdir
54         dh_testroot
55         rm -f build-stamp configure-stamp
56
57         # Add here commands to clean up after the build process.
58         -$(MAKE) clean
59
60         dh_clean 
61
62 install: build
63         dh_testdir
64         dh_testroot
65         dh_clean -k 
66         dh_installdirs
67
68 # Add here commands to install the package into debian/webcit.
69         root=$(CURDIR)/debian/webcit/
70         export root=$(CURDIR)/debian/citadel-webcit; \
71                 $(MAKE) install DESTDIR=$(CURDIR)/debian/citadel-webcit
72         mkdir -p $(CURDIR)/debian/citadel-webcit/usr/lib/citadel-webcit ;\
73         mv $(CURDIR)/debian/citadel-webcit/usr/sbin/setup \
74                 $(CURDIR)/debian/citadel-webcit/usr/lib/citadel-webcit/; \
75         cd $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples/ && \
76                                 md5sum `find -type f |grep -v md5sums `>md5sums; \
77
78
79 # Build architecture-independent files here.
80 binary-indep: build install
81 # We have nothing to do by default.
82
83 # Build architecture-dependent files here.
84 binary-arch: build install
85         dh_testdir
86         dh_testroot
87         dh_installchangelogs ChangeLog
88         dh_installdocs
89         dh_installexamples
90 #       dh_install
91 #       dh_installmenu
92         dh_installdebconf       
93 #       dh_installlogrotate
94 #       dh_installemacsen
95 #       dh_installpam
96 #       dh_installmime
97 #       dh_installinit
98 #       dh_installcron
99 #       dh_installinfo
100         dh_installman
101         dh_link
102         dh_strip
103         dh_compress
104         dh_fixperms
105 #       dh_perl
106 #       dh_python
107 #       dh_makeshlibs
108         dh_installdeb
109         dh_shlibdeps
110         dh_gencontrol
111         dh_md5sums
112         dh_builddeb
113
114 binary: binary-indep binary-arch
115 .PHONY: build clean binary-indep binary-arch binary install configure