* fixed locale directory lookup / make
[citadel.git] / webcit / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12 DESTDIR=$(CURDIR)/debian/citadel-webcit/
13
14
15
16 CFLAGS = -Wall -g -ggdb
17
18 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
19         CFLAGS += -O0
20 else
21         CFLAGS += -O0 -ggdb
22 endif
23
24 configure: configure-stamp
25 configure-stamp:
26         dh_testdir
27         CFLAGS="$(CFLAGS)" ./configure \
28                 --host=$(DEB_HOST_GNU_TYPE) \
29                 --build=$(DEB_BUILD_GNU_TYPE) \
30                 --prefix=/usr/sbin/ \
31                 --with-wwwdir=/usr/share/citadel-webcit \
32                 --with-localedir=/usr/share/ \
33                 --with-editordir=/usr/share/tinymce/www \
34                 --with-rundir=/var/run/citadel \
35                 --with-ical --with-db --with-ldap \
36                 --with-zlib --with-ssl --with-libiconf \
37                 --with-newt --with-included-gettext
38
39         touch configure-stamp
40
41
42 build: build-stamp
43
44 build-stamp: configure-stamp 
45         dh_testdir
46
47 # Add here commands to compile the package.
48         $(MAKE)
49 #docbook-to-man debian/webcit.sgml > webcit.1
50
51         touch build-stamp
52
53 clean:
54         dh_testdir
55         dh_testroot
56         rm -f build-stamp configure-stamp
57
58 # Add here commands to clean up after the build process.
59         -$(MAKE) clean
60
61         dh_clean 
62
63 install: build
64         dh_testdir
65         dh_testroot
66         dh_clean -k 
67         dh_installdirs
68         $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
69 #       mkdir -p $(DESTDIR)/etc/citadel; cp webcit.conf $(DESTDIR)/etc/citadel/
70
71
72
73 # Build architecture-independent files here.
74 binary-indep: build install
75 # We have nothing to do by default.
76
77 # Build architecture-dependent files here.
78 binary-arch: build install
79         dh_testdir
80         dh_testroot
81 #       dh_installchangelogs ChangeLog
82         dh_installdocs
83         dh_installexamples
84         dh_install
85 #       dh_installmenu
86         dh_installdebconf       
87 #       dh_installlogrotate
88 #       dh_installemacsen
89 #       dh_installpam
90 #       dh_installmime
91         dh_installinit --name=webcit
92 #       dh_installcron
93 #       dh_installinfo
94         dh_installman
95         dh_link
96         dh_strip
97         dh_compress
98         dh_fixperms
99 #       dh_perl
100 #       dh_python
101 #       dh_makeshlibs
102         dh_installdeb
103         dh_shlibdeps
104         dh_gencontrol
105         dh_md5sums
106         dh_builddeb
107
108 binary: binary-indep binary-arch
109 .PHONY: build clean binary-indep binary-arch binary install configure