]> code.citadel.org Git - citadel.git/blob - citadel/citadel.spec
* [EXPERIMENTAL] Link in the "libical" calendar library if present
[citadel.git] / citadel / citadel.spec
1 # $Id$
2 Summary: Citadel/UX, the flexible, powerful way to build online communities
3 Name: citadel
4 Version: 6.00
5 Release: 1
6 Copyright: GPL
7 Group: Applications/Communications
8 Source0: http://uncensored.citadel.org/pub/citadel/citadel-ux-%{PACKAGE_VERSION}.tar.gz
9 Buildroot: /var/tmp/citadel-%{PACKAGE_VERSION}-root
10 #Icon: citux-64x64.xpm
11 Vendor: Citadel/UX Development Team
12 URL:  http://uncensored.citadel.org/citadel/
13 #Autoprov: false
14 ExcludeOS: hpux
15
16 %description
17 An advanced messaging system which can be used for BBS, groupware, and
18 online community applications.  It is multithreaded, client/server, database
19 driven, and accessible via a growing selection of front ends.
20
21 %prep
22 %setup -n citadel
23
24 %build
25 CFLAGS="$RPM_OPT_FLAGS" ./configure --with-pam
26 make
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 mkdir -p $RPM_BUILD_ROOT/etc/pam.d
31 make root=$RPM_BUILD_ROOT install
32 touch $RPM_BUILD_ROOT/usr/local/citadel/.hushlogin
33
34 %clean
35 rm -rf "$RPM_BUILD_ROOT"
36
37 %package server
38 Summary: Citadel/UX, the flexible, powerful way to build online communities
39 Group: System Environment/Daemons
40 Requires: citadel-data
41 Obsoletes: citadel
42 Obsoletes: citadel-ux
43 %description server
44 Citadel/UX is an advanced messaging system which can be used for BBS,
45 groupware, and online community applications.  It is multithreaded,
46 client/server, database driven, and accessible via a growing selection of
47 front ends.  Remember to run /usr/local/citadel/setup after installing or
48 upgrading this package.
49 %defattr(-,root,root)
50 %files server
51 /etc/pam.d/citadel
52 %doc docs/chat.txt
53 %doc docs/citadel-with-berkeley-db.txt
54 %doc docs/COPYING.txt
55 %doc docs/copyright.txt
56 %doc docs/import-export.txt
57 %doc docs/inetsiteconfig.txt
58 %doc docs/mailinglists.txt
59 %doc docs/room-sharing-howto.txt
60 %doc docs/siteconfig.txt
61 %doc docs/sysop.txt
62 %doc docs/upgrading.txt
63 %doc docs/utils.txt
64 %dir /usr/local/citadel/bio
65 %dir /usr/local/citadel/bitbucket
66 %dir /usr/local/citadel/files
67 %dir /usr/local/citadel/images
68 %dir /usr/local/citadel/info
69 %dir /usr/local/citadel/userpics
70 /usr/local/citadel/aidepost
71 /usr/local/citadel/base64
72 %attr(4755,root,root) /usr/local/citadel/chkpwd
73 /usr/local/citadel/citmail
74 /usr/local/citadel/citserver
75 /usr/local/citadel/libcitserver.so
76 /usr/local/citadel/libcitserver.la
77 /usr/local/citadel/migratenet
78 /usr/local/citadel/msgform
79 /usr/local/citadel/readlog
80 /usr/local/citadel/sendcommand
81 /usr/local/citadel/setup
82 /usr/local/citadel/stats
83 /usr/local/citadel/userlist
84 /usr/local/citadel/utilsmenu
85 /usr/local/citadel/weekly
86 /usr/local/citadel/modules/libchat.so
87 /usr/local/citadel/modules/libchat.la
88 /usr/local/citadel/modules/libvcard.so
89 /usr/local/citadel/modules/libvcard.la
90 /usr/local/citadel/modules/libupgrade.so
91 /usr/local/citadel/modules/libupgrade.la
92 /usr/local/citadel/modules/libnetwork.so
93 /usr/local/citadel/modules/libnetwork.la
94 /usr/local/citadel/modules/libpas2.so
95 /usr/local/citadel/modules/libpas2.la
96 /usr/local/citadel/modules/libinetcfg.so
97 /usr/local/citadel/modules/libinetcfg.la
98 /usr/local/citadel/modules/librwho.so
99 /usr/local/citadel/modules/librwho.la
100 /usr/local/citadel/modules/libmoderate.so
101 /usr/local/citadel/modules/libmoderate.la
102 /usr/local/citadel/modules/libbio.so
103 /usr/local/citadel/modules/libbio.la
104 /usr/local/citadel/modules/libexpire.so
105 /usr/local/citadel/modules/libexpire.la
106 /usr/local/citadel/modules/libvandelay.so
107 /usr/local/citadel/modules/libvandelay.la
108 /usr/local/citadel/modules/libcalendar.so
109 /usr/local/citadel/modules/libcalendar.la
110 /usr/local/citadel/modules/liblistsub.so
111 /usr/local/citadel/modules/liblistsub.la
112 /usr/local/citadel/modules/libmrtg.so
113 /usr/local/citadel/modules/libmrtg.la
114 /usr/local/citadel/modules/libnetfilter.so
115 /usr/local/citadel/modules/libnetfilter.la
116 # Not in use yet
117 #/usr/local/citadel/modules/libspam.so
118 #/usr/local/citadel/modules/libspam.la
119 %pre server
120 # Add the "bbs" user
121 /usr/sbin/useradd -c "Citadel" -s /bin/false -r -d /usr/local/citadel \
122                 citadel 2> /dev/null || :
123 %post server
124 if [ -f /etc/inittab ]; then
125         if ! grep 'citserver' /etc/inittab > /dev/null; then
126                 echo "c1:2345:/usr/local/citadel/citserver -h/usr/local/citadel -t/usr/local/citadel/citserver.trace" >> /etc/inittab
127         fi
128 fi
129 if [ -f /etc/services ]; then
130         if ! grep '^citadel' /etc/services > /dev/null; then
131                 echo "citadel           504/tcp         # citadel" >> /etc/services
132         fi
133 fi
134 /sbin/ldconfig -n /usr/local/citadel /usr/local/citadel/modules
135 cd /usr/local/citadel
136 /usr/local/citadel/setup -q
137 %postun server
138 if [ -f /etc/inittab ]; then
139         grep -v 'citserver' < /etc/inittab > /etc/inittab.new && \
140         mv /etc/inittab.new /etc/inittab
141         /sbin/init q
142 fi
143
144 %package data
145 Summary: Data files for the Citadel/UX messaging system.
146 Group: System Environment/Daemons
147 %description data
148 Default data files for the Citadel/UX messaging system.  These files are
149 required by the Citadel/UX server.
150 %defattr(-,root,root)
151 %files data
152 /usr/local/citadel/.hushlogin
153 #%dir /usr/local/citadel/netconfigs
154 %dir /usr/local/citadel/network
155 %dir /usr/local/citadel/network/spoolin
156 %dir /usr/local/citadel/network/spoolout
157 %dir /usr/local/citadel/network/systems
158 %config(noreplace) /usr/local/citadel/network/filterlist
159 %config(noreplace) /usr/local/citadel/network/mail.aliases
160 %config(noreplace) /usr/local/citadel/network/mailinglists
161 %config(noreplace) /usr/local/citadel/network/rnews.xref
162 %config(noreplace) /usr/local/citadel/public_clients
163 # KLUDGE!!!!  This catches help/? otherwise RPM barfs on it
164 # Drawback, it's not marked as a config file, oh well
165 /usr/local/citadel/help
166 #%config /usr/local/citadel/help/?
167 #%config /usr/local/citadel/help/aide
168 #%config /usr/local/citadel/help/software
169 #%config /usr/local/citadel/help/floors
170 #%config(noreplace) /usr/local/citadel/help/hours
171 #%config /usr/local/citadel/help/intro
172 #%config /usr/local/citadel/help/mail
173 #%config /usr/local/citadel/help/network
174 #%config /usr/local/citadel/help/nice
175 #%config(noreplace) /usr/local/citadel/help/policy
176 #%config /usr/local/citadel/help/summary
177 %config /usr/local/citadel/messages/changepw
178 %config /usr/local/citadel/messages/aideopt
179 %config /usr/local/citadel/messages/entermsg
180 %config /usr/local/citadel/messages/dotopt
181 %config /usr/local/citadel/messages/mainmenu
182 %config /usr/local/citadel/messages/entopt
183 %config(noreplace) /usr/local/citadel/messages/goodbye
184 %config(noreplace) /usr/local/citadel/messages/hello
185 %config /usr/local/citadel/messages/help
186 %config(noreplace) /usr/local/citadel/messages/register
187 %config(noreplace) /usr/local/citadel/messages/newuser
188 %config /usr/local/citadel/messages/readopt
189 %config /usr/local/citadel/messages/roomaccess
190 %config(noreplace) /usr/local/citadel/messages/unlisted
191
192 %package client
193 Summary: Client for the Citadel/UX messaging system
194 Group: Applications/Communications
195 %description client
196 This is the text client software for the Citadel/UX messaging system.
197 Install this software if you need to connect to a Citadel/UX server.
198 %defattr(-,root,root)
199 %files client
200 /usr/local/citadel/citadel
201 /usr/local/citadel/citadel.rc
202 %doc docs/chat.txt
203 %post client
204 if [ -f /etc/services ]; then
205         if ! grep '^citadel' /etc/services > /dev/null; then
206                 echo "citadel           504/tcp         # citadel" >> /etc/services
207         fi
208 fi
209
210 %package smtp
211 Summary: SMTP server for the Citadel/UX messaging system
212 Group: System Environment/Daemons
213 %description smtp
214 This package provides the Citadel/UX SMTP service, which provides inbound
215 and outbound SMTP service for the Citadel/UX messaging system.  Install this
216 package if your Citadel/UX users should be able to send and receive Internet
217 e-mail.  If you also run another SMTP server you will need to read
218 docs/inetmailsetupmx.txt to configure SMTP service.
219 %defattr(-,root,root)
220 %files smtp
221 /usr/local/citadel/modules/libsmtp.so
222 /usr/local/citadel/modules/libsmtp.la
223 %doc docs/inetmailsetupmx.txt
224 %doc docs/inetmailsetup.txt
225
226 %package imap
227 Summary: IMAP server for the Citadel/UX messaging system
228 Group: System Environment/Daemons
229 %description imap
230 This package provides the Citadel/UX IMAP service, which provides IMAP
231 connectivity.  Install this package if you want to connect to the Citadel/UX
232 server with IMAP clients such as Outlook Express or Netscape.  Using this
233 access method, users can access both e-mail and all public rooms on the server.
234 %defattr(-,root,root)
235 %files imap
236 /usr/local/citadel/modules/libimap.so
237 /usr/local/citadel/modules/libimap.la
238
239 %package pop3
240 Summary: POP3 server for the Citadel/UX messaging system
241 Group: System Environment/Daemons
242 %description pop3
243 This package provides the Citadel/UX POP3 service, which provides POP3
244 connectivity.  Install this package if you want to connect to the Citadel/UX
245 server with POP3 clients such as Outlook Express or Netscape.  Note that the
246 POP3 client can only receive mail; install citadel-smtp as well if you want
247 users to be able to send mail.
248 %defattr(-,root,root)
249 %files pop3
250 /usr/local/citadel/modules/libpop3.so
251 /usr/local/citadel/modules/libpop3.la
252