]> code.citadel.org Git - citadel.git/blobdiff - citadel/debian/rules
* add some script to wrap the debian package build that does some magic about
[citadel.git] / citadel / debian / rules
index a1826e715214445cc2c9c5c68b7c0693379acaec..9af35c279b1ea9d6efda48d0ae96cf56e334616d 100755 (executable)
@@ -24,11 +24,11 @@ export VERSION=`grep 'THIS IS' $(CURDIR)/ChangeLog  |head -n 1 |sed "s;.* ;;"`
 
 CFLAGS = -Wall -g
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
+#ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -O0 -ggdb
+#else
+#      CFLAGS += -O2
+#endif
 
 config.status: configure
        dh_testdir
@@ -41,6 +41,7 @@ config.status: configure
                --with-datadir=/var/lib/citadel \
                --with-rundir=/var/run/citadel \
                --with-docdir=/usr/share/doc/citadel-doc/ \
+               --enable-autologin \
                --with-ical --with-db --with-ldap