Internal version number to 8.01 for imminent release
[citadel.git] / citadel / configure.ac
index f59fe78e69fdf8d7dcca2d86164aa9daba859a15..1cecac52bb239350bf100cb74599e0c63e5c20c6 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 AC_PREREQ(2.52)
-AC_INIT([Citadel], [7.89], [http://www.citadel.org/])
+AC_INIT([Citadel], [8.01], [http://www.citadel.org/])
 AC_REVISION([$Revision: 5108 $])
 AC_CONFIG_SRCDIR([citserver.c])
 AC_CONFIG_HEADER(sysdep.h)
@@ -398,6 +398,8 @@ AC_SUBST(DEPEND_FLAG)
 
 AC_PROG_INSTALL
 AC_PROG_YACC
+AC_PATH_PROG(DIFF,diff)
+AC_PATH_PROG(PATCH,patch)
 missing_dir=`cd $ac_aux_dir && pwd`
 AM_MISSING_PROG(AUTOCONF, autoconf, $missing_dir)
 AM_MISSING_PROG(ACLOCAL, aclocal, $missing_dir)
@@ -439,7 +441,7 @@ fi
 if test "$ok_nls" != "no"; then
        AC_MSG_RESULT(citadel will be built with national language support.)
        AC_DEFINE(ENABLE_NLS, [], [whether we have NLS support])
-       PROG_SUBDIRS="$PROG_SUBDIRS po"
+       PROG_SUBDIRS="$PROG_SUBDIRS po/citadel-setup"
 else
        AC_MSG_RESULT(citadel will be built without national language support.)
 fi
@@ -467,16 +469,6 @@ AC_ARG_WITH(gprof,
                        ]
 )
 
-dnl disable thread table reporting
-AC_ARG_WITH(threadlog,
-               [  --with-threadlog        enable logging of thread table],
-                       [ if test "x$withval" != "xno" ; then
-                               AC_DEFINE(WITH_THREADLOG, [], [Define if you want logging of the thread tables.])
-                         fi
-                       ]
-)
-
-
 if test "$ac_cv_func_gethostbyname" = no; then
        AC_CHECK_LIB(nsl, gethostbyname)
 fi
@@ -735,22 +727,6 @@ fi
 
 
 
-dnl Checks for the Boehm-Demers-Weiser garbage collection library.
-if test "x$with_gc" != xno ; then
-       AC_CHECK_HEADERS(gc/gc_local_alloc.h,
-               [AC_CHECK_LIB(gc, GC_init,
-                       [ok_gc=yes],,
-       )])
-fi
-
-if test "x$ok_gc" = xyes ; then
-       SERVER_LIBS="-lgc $SERVER_LIBS"
-       AC_DEFINE(HAVE_GC, [], [define this if you have Boehm-Demers-Weiser available])
-fi
-
-
-
-
 
 dnl Checks for the libdspam mail spam scanning library.
 dnl if test "x$with_libdspam" != xno ; then
@@ -1015,10 +991,7 @@ AC_CACHE_CHECK([under the bed], ac_cv_under_the_bed, [
 
 STRUCT_UCRED
 
-
-
 dnl Done! Now write the Makefile and sysdep.h
-AC_SUBST(AUTH)
 AC_SUBST(RESOLV)
 AC_SUBST(chkpwd_LIBS)
 AC_SUBST(TARGETS)
@@ -1026,8 +999,10 @@ AC_SUBST(DATABASE)
 AC_SUBST(SERVER_LDFLAGS)
 AC_SUBST(SERVER_LIBS)
 AC_SUBST(SETUP_LIBS)
+AC_SUBST(DIFF)
+AC_SUBST(PATCH)
 AC_CONFIG_FILES([Makefile])
-AC_OUTPUT(database_cleanup.sh po/Makefile)
+AC_OUTPUT(database_cleanup.sh po/citadel-setup/Makefile)
 
 if test -z "$DATABASE"; then
        AC_MSG_WARN([No database driver was found. Please install Berkeley DB.])