'Network User' is now 'Normal User'
[citadel.git] / citadel / debian / rules
index ef15cba83710e5b7371bc7296b424cd34f96aed2..431f8985a6c4c289a468dc2b65d0862513b0b307 100755 (executable)
@@ -25,7 +25,7 @@ ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
 endif
 
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP -D TECH_PREVIEW
+       CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP -D TECH_PREVIEW -Wcast-align
        LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
        EXTRA_ARGS = --with-backtrace
        ifneq (,$(findstring event,$(DEB_BUILD_OPTIONS)))
@@ -59,7 +59,7 @@ ifneq (,$(findstring cares,$(DEB_BUILD_OPTIONS)))
 endif
 
 ifneq (,$(findstring iodbg,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -D BIGBAD_IODBG
+       CFLAGS += -D BIGBAD_IODBG -D LDAP_INITIALIZE
 endif
 
 ifneq (,$(findstring gcov,$(DEB_BUILD_OPTIONS)))