Update config.guess and config.sub. Fix chdir() and -h in webcit
[citadel.git] / webcit / configure.ac
index 1bdca0631d3788b7d87216ec10e77ca3e92e0500..8cc9c27f3c15ff24bdace33806d59cf7bf2e0f53 100644 (file)
@@ -1,7 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
-AC_INIT([WebCit], [8.29], [http://www.citadel.org/])
-
+AC_INIT([WebCit],m4_esyscmd_s([grep CLIENT_VERSION webcit.h | sed 's/[^0-9]*//g']),[http://uncensored.citadel.org])
 
 AC_SUBST(PROG_SUBDIRS)
 AC_DEFINE(PROG_SUBDIRS, [], [Program dirs])
@@ -88,6 +87,7 @@ dnl Checks for header files.
 AC_HEADER_STDC
 dnl AC_HEADER_SYS_WAIT
 
+AC_CHECK_FUNCS(crypt gethostbyname connect flock getpwnam_r getpwuid_r getloadavg)
 AC_CACHE_CHECK(
        [for call semantics from getpwuid_r], 
        ac_cv_call_getpwuid_r,
@@ -137,7 +137,7 @@ dnl AC_FUNC_VPRINTF
 AC_REPLACE_FUNCS(snprintf)
 AC_CHECK_HEADER(CUnit/CUnit.h, [AC_DEFINE(ENABLE_TESTS, [], [whether we should compile the test-suite])])
 
-AC_CHECK_HEADERS(fcntl.h limits.h sys/time.h unistd.h iconv.h xlocale.h)
+AC_CHECK_HEADERS(fcntl.h limits.h unistd.h iconv.h xlocale.h)
 
 dnl Checks for the zlib compression library.
 saved_CFLAGS="$CFLAGS"
@@ -214,7 +214,6 @@ else
        AC_MSG_RESULT(webcit will be built without character set conversion.)
 fi
 
-
 AC_CHECK_LIB(intl, libintl_bindtextdomain, [LDFLAGS="$LDFLAGS -lintl"])
 
 
@@ -238,7 +237,7 @@ dnl Checks for the discount markdown library.
 AC_CHECK_LIB(markdown,
         markdown,
         [
-        LDFLAGS="$LDFLAGS -lmarkdown"
+        LIBS="$LIBS -lmarkdown"
         AC_DEFINE(HAVE_MARKDOWN,[],[whether we have markdown message rendering])
 ])
 
@@ -561,16 +560,6 @@ AC_ARG_WITH(editordir,
                          fi
                        ]
 )
-AC_DEFINE_UNQUOTED(EDITORDIR, "$editordir", [where to find our mail editor])
-
-AC_ARG_WITH(markdowneditordir, 
-                   [  --with-markdowneditordir             directory to put our markdown editor],
-                       [ if test "x$withval" != "xno" ; then
-                               markdowneditordir=$withval
-                         fi
-                       ]
-)
-AC_DEFINE_UNQUOTED(MARKDOWNEDITORDIR, "$markdowneditordir", [where to find our markdown editor])
 
 dnl Checks where to find our configs
 AC_ARG_WITH(etcdir,