Update config.guess and config.sub. Fix chdir() and -h in webcit
[citadel.git] / webcit / configure.ac
index 6819bb28a03ad48f3558cec5b3cfec23492aa434..8cc9c27f3c15ff24bdace33806d59cf7bf2e0f53 100644 (file)
@@ -1,7 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
-AC_INIT([WebCit], [8.03], [http://www.citadel.org/])
-
+AC_INIT([WebCit],m4_esyscmd_s([grep CLIENT_VERSION webcit.h | sed 's/[^0-9]*//g']),[http://uncensored.citadel.org])
 
 AC_SUBST(PROG_SUBDIRS)
 AC_DEFINE(PROG_SUBDIRS, [], [Program dirs])
@@ -88,6 +87,7 @@ dnl Checks for header files.
 AC_HEADER_STDC
 dnl AC_HEADER_SYS_WAIT
 
+AC_CHECK_FUNCS(crypt gethostbyname connect flock getpwnam_r getpwuid_r getloadavg)
 AC_CACHE_CHECK(
        [for call semantics from getpwuid_r], 
        ac_cv_call_getpwuid_r,
@@ -137,21 +137,26 @@ dnl AC_FUNC_VPRINTF
 AC_REPLACE_FUNCS(snprintf)
 AC_CHECK_HEADER(CUnit/CUnit.h, [AC_DEFINE(ENABLE_TESTS, [], [whether we should compile the test-suite])])
 
-AC_CHECK_HEADERS(fcntl.h limits.h sys/time.h unistd.h iconv.h xlocale.h)
+AC_CHECK_HEADERS(fcntl.h limits.h unistd.h iconv.h xlocale.h)
 
 dnl Checks for the zlib compression library.
-if test "x$with_zlib" != xno ; then
-       AC_CHECK_HEADERS(zlib.h,
-               [AC_CHECK_LIB(z, zlibVersion,
-                       [ok_zlib=yes],,
-       )])
-fi
-
-if test "x$ok_zlib" = xyes ; then
-dnl  libcitadel will bring libz, so we don't need it here.     LDFLAGS="-lz $LDFLAGS" 
-       AC_DEFINE(HAVE_ZLIB, [], [define this if you have zlib compression available])
-fi
-
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS $SERVER_LIBS"
+AC_CHECK_HEADER(zlib.h,
+       [AC_CHECK_LIB(z, zlibVersion,
+               [
+                       LIBS="-lz $LIBS $SERVER_LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(zlib was not found or is not usable.  Please install zlib.)
+               ]
+       ,
+       )],
+       [
+               AC_MSG_ERROR(zlib.h was not found or is not usable.  Please install zlib.)
+       ]
+)
+CFLAGS="$saved_CFLAGS"
 
 dnl Here is the check for a libc integrated iconv
 AC_ARG_ENABLE(iconv,
@@ -209,7 +214,6 @@ else
        AC_MSG_RESULT(webcit will be built without character set conversion.)
 fi
 
-
 AC_CHECK_LIB(intl, libintl_bindtextdomain, [LDFLAGS="$LDFLAGS -lintl"])
 
 
@@ -229,6 +233,13 @@ AC_CHECK_HEADER(libical/ical.h,
        ]
 )
 
+dnl Checks for the discount markdown library.
+AC_CHECK_LIB(markdown,
+        markdown,
+        [
+        LIBS="$LIBS -lmarkdown"
+        AC_DEFINE(HAVE_MARKDOWN,[],[whether we have markdown message rendering])
+])
 
 dnl Check for libcitadel
 AC_CHECK_HEADER(libcitadel.h,
@@ -247,6 +258,35 @@ AC_CHECK_HEADER(libcitadel.h,
        ]
 )
 
+AC_MSG_CHECKING([whether your system likes memcpy + HKEY]) 
+AC_TRY_COMPILE([
+#define _GNU_SOURCE
+#include <ctype.h>
+#include <errno.h>
+#include <string.h>
+#include <unistd.h>
+#include <string.h>
+#include <stdio.h>
+#include <sys/select.h>
+#include <fcntl.h>
+#include <sys/types.h>
+
+#include "lib/libcitadel.h"
+],
+[
+       char foo[22];
+       memcpy(foo, HKEY("foo"));
+       
+],
+               [
+
+                 AC_MSG_RESULT([yes])
+               ],
+               [ 
+                 AC_DEFINE(UNDEF_MEMCPY, [], [whether we need to undefine memcpy])
+                 AC_MSG_RESULT([no])
+               ]
+)
 
 dnl Checks for the Expat XML parser.
 AC_CHECK_HEADER(expat.h,
@@ -452,12 +492,16 @@ if test "$prefix" = NONE; then
        wwwdir=$ac_default_prefix
        rundir=$ac_default_prefix
        editordir=$ac_default_prefix/tiny_mce
+       markdowneditordir=$ac_default_prefix/epic
+       etcdir=$ac_default_prefix
 else
        localedir=$prefix
        wwwdir=$prefix
        datadir=$prefix
        rundir=$prefix
        editordir=$prefix/tiny_mce
+       markdowneditordir=$prefix/epic
+       etcdir=$prefix
 fi
 
 dnl where to put the locale files
@@ -516,7 +560,18 @@ AC_ARG_WITH(editordir,
                          fi
                        ]
 )
-AC_DEFINE_UNQUOTED(EDITORDIR, "$editordir", [where to find our mail editor])
+
+dnl Checks where to find our configs
+AC_ARG_WITH(etcdir, 
+                   [  --with-etcdir             directory to read our configs],
+                       [ if test "x$withval" != "xno" ; then
+                               etcdir=$withval
+                         fi
+                       ]
+)
+AC_DEFINE_UNQUOTED(ETCDIR, "$etcdir", [where to find our configs])
+ETCDIR=$etcdir
+AC_SUBST(ETCDIR)
 
 abs_srcdir="`cd $srcdir && pwd`"
 abs_builddir="`pwd`"
@@ -529,6 +584,7 @@ AC_OUTPUT(Makefile po/webcit/Makefile tests/Makefile)
 if test "$abs_srcdir" != "$abs_builddir"; then
    ln -s $abs_srcdir/static $abs_builddir
    ln -s $abs_srcdir/tiny_mce $abs_builddir
+   ln -s $abs_srcdir/epic $abs_builddir
    ln -s $abs_srcdir/*.h $abs_builddir
    make mkdir-init
    
@@ -547,5 +603,4 @@ fi
 echo ------------------------------------------------------------------------
 echo 'Character set conversion support:' $ok_iconv
 echo 'National language support:       ' $ok_nls
-echo 'Compression support:             ' $ok_zlib
 echo