* just modify /etc/services in batch mode if we are told so by the environment variab...
[citadel.git] / citadel / debian / citadel-server.postinst
1 #!/bin/sh
2 # postinst script for citadel-server
3
4 set -e
5
6 # source debconf stuff
7 . /usr/share/debconf/confmodule
8 db_version 2.0
9
10 # glitch: this mustn't be in /var/run/
11 if test -f /var/run/refcount_adjustments.dat; then
12     mv /var/run/refcount_adjustments.dat /etc/citadel/
13 fi
14 case "$1" in
15     configure)
16         chown -R citadel:citadel /etc/citadel
17         chown -R citadel:citadel /var/lib/citadel /var/spool/citadel
18
19         db_get citadel/Administrator && admin="$RET"
20         db_get citadel/ServerIPAddress && ip_addr="$RET"
21         db_get citadel/LoginType && deb_enable_unix_auth="$RET"
22
23         if test "$deb_enable_unix_auth" = "true"; then
24             export ENABLE_UNIX_AUTH=yes
25         else
26             export ENABLE_UNIX_AUTH=no
27         fi
28
29         export IP_ADDR=$ip_addr
30         export CITADEL=''
31         export CITADEL_PORT=504
32         export CITADEL_INSTALLER=yes
33         export CITADEL_UID=`grep citadel /etc/passwd | cut -d :  -f 3`
34         export ACT_AS_MTA=no
35         export SYSADMIN_NAME=$admin
36         export CREATE_XINETD_ENTRY=no
37         export CREATE_INITTAB_ENTRY=no
38         export NO_INIT_SCRIPTS=yes
39
40 #This is not debian conformant, and uniq to the citadel.org debs.
41         export ALTER_ETC_SERVICES=yes
42 #
43         echo "applying your settings."
44         /usr/lib/citadel-server/setup -q
45
46         # we're in a fresh install, so we send the welcome message.
47         if test -z "$2"; then
48             export SEPERATOR=2600908b3f21ae7f692b973ed26e212d
49             export WELCOMEHTML=/usr/share/doc/citadel-server/welcomemail.html
50             export WELCOMETXT=/usr/share/doc/citadel-server/welcomemail.txt
51             export FROM=room_citadel_stats@uncensored.citadel.org
52             export TO=room_lobby
53             (
54                 printf "MIME-Version: 1.0\r\nContent-Type: multipart/alternative; \r\n boundary=$SEPERATOR\r\n\r\nThis is a multi-part message in MIME format.\r\n\r\n--$SEPERATOR\r\nContent-Type: text/plain; charset=utf-8\r\nContent-Transfer-Encoding: quoted-printable\r\n\r\n"; 
55                 cat $WELCOMETXT
56                 printf "\r\n\r\n--$SEPERATOR\r\nContent-Type: text/html; charset=US-ASCII\r\nContent-Transfer-Encoding: quoted-printable\r\n\r\n"
57                 cat $WELCOMEHTML; 
58                 printf "\r\n\r\n--$SEPERATOR--\r\n\r\n") | \
59                     /usr/sbin/citmail -bm -r "$FROM" "$TO"
60             /usr/lib/citadel-server/migrate_aliases.sh /etc/citadel/mail.aliases
61         fi
62
63         if test -S /var/run/citadel/citadel.socket; then 
64             /usr/sbin/sendcommand "DOWN"
65         fi
66
67         while test -S /var/run/citadel/citadel.socket; do 
68             sleep 1
69         done
70
71         db_stop
72     ;;
73
74     abort-upgrade|abort-remove|abort-deconfigure)
75     ;;
76
77     *)
78         echo "postinst called with unknown argument \`$1'" >&2
79         exit 1
80     ;;
81 esac
82
83 #DEBHELPER#
84
85 exit 0