* Added in Wilfried Goesgens' debian/ build directory.
[citadel.git] / citadel / debian / citadel-server.postinst
1 #! /bin/sh
2 # postinst.skeleton
3 # Skeleton maintainer script showing all the possible cases.
4 # Written by Charles Briscoe-Smith, March-June 1998.  Public Domain.
5
6 # Abort if any command returns an error value
7 set -e
8
9 # Use debconf.
10 . /usr/share/debconf/confmodule
11
12 # This script is called as the last step of the installation of the
13 # package.  All the package's files are in place, dpkg has already done
14 # its automatic conffile handling, and all the packages we depend of
15 # are already fully installed and configured.
16
17 # The following idempotent stuff doesn't generally need protecting
18 # against being run in the abort-* cases.
19
20 #### Install info files into the dir file
21 ###: install-info --quiet --section "section pattern" "Section Title" \
22 ###:              --description="Name of the document" /usr/info/foo.info
23 ###
24 #### Create stub directories under /usr/local
25 ###: if test ! -d /usr/local/lib/foo; then
26 ###:   if test ! -d /usr/local/lib; then
27 ###:     if mkdir /usr/local/lib; then
28 ###:       chown root.staff /usr/local/lib || true
29 ###:       chmod 2775 /usr/local/lib || true
30 ###:     fi
31 ###:   fi
32 ###:   if mkdir /usr/local/lib/foo; then
33 ###:     chown root.staff /usr/local/lib/foo || true
34 ###:     chmod 2775 /usr/local/lib/foo || true
35 ###:   fi
36 ###: fi
37 ###
38 #### Ensure the menu system is updated
39 ###: [ ! -x /usr/bin/update-menus ] || /usr/bin/update-menus
40 ###
41 #### Arrange for a daemon to be started at system boot time
42 ###: update-rc.d foo default >/dev/null
43 ###
44
45 case "$1" in
46   configure)
47     # Configure this package.  If the package must prompt the user for
48     # information, do it here.
49     if ! getent group citadel >/dev/null; then 
50                 groupadd --system citadel
51         fi
52         if ! getent passwd citadel >/dev/null; then 
53                 adduser --system --ingroup citadel --home /var/lib/citadel \
54                         --gecos "Citadel system user" --shell /bin/sh \
55                         --disabled-password citadel
56         fi
57         mkdir -p /etc/citadel
58     # Activate menu-methods script
59     #: chmod a+x /etc/menu-methods/foo
60
61     # Update ld.so cache
62     #: ldconfig
63
64     # Make our version of a program available
65     #: update-alternatives \
66     #:       --install /usr/bin/program program /usr/bin/alternative 50 \
67     #:       --slave /usr/share/man/man1/program.1.gz program.1.gz \
68     #:               /usr/share/man/man1/alternative.1.gz
69
70     # Tell ucf that the file in /usr/share/foo is the latest
71     # maintainer version, and let it handle how to manage the real
72     # confuguration file in /etc. This is how a static configuration
73     # file can be handled:
74     ucf /usr/share/doc/citadel-server/examples/mail.aliases /etc/citadel/mail.aliases
75     ucf /usr/share/doc/citadel-server/examples/public_clients /etc/citadel/public_clients
76
77         #: !TODO: should network/systems  go to /etc/citadel?
78
79 #       mkdir -p \
80 #               /var/lib/citadel/help \
81 #               /var/lib/citadel/messages \
82 #               /var/lib/citadel/data/ \
83 #               /var/lib/citadel/bio/ \
84 #               /var/lib/citadel/bitbucket/ \
85 #               /var/lib/citadel/files/ \
86 #               /var/lib/citadel/images/ \
87 #               /var/lib/citadel/info/ \
88 #               /var/lib/citadel/userpics/ \
89 #               /var/spool/citadel/network/spoolin \
90 #               /var/spool/citadel/network/spoolout \
91 #               /var/spool/citadel/network/spoolsystems \
92 #               /var/run/citadel
93 #
94
95         for i in  '?' aide  floors  hours  intro.gz  mail  network  nice.gz  policy  software  summary.gz; do
96                 case $i in 
97                         *.gz)
98                                 j=`echo $i|sed "s;.gz;;"`
99                                 gunzip -c "/usr/share/doc/citadel-server/examples/help/$i" >"/tmp/$j"
100                                 i=$j
101                                 ;;
102                         *)
103                                 cp "/usr/share/doc/citadel-server/examples/help/$i" "/tmp"
104                                 ;;
105                 esac
106                 ucf "/tmp/$i" "/var/lib/citadel/help/$i"
107                 rm -f "/tmp/$i"
108         done
109         
110 #       # TODO: there is a file named '?'. this gives trouble with ucf, so do it by hand for now.
111 #       if test ! -e '/var/lib/citadel/help/?'; then 
112 #               cp '/usr/share/doc/citadel/examples/data/help/?' '/var/lib/citadel/help'
113 #       fi
114         for i in aideopt  changepw  dotopt  entermsg  entopt  goodbye  hello  help  mainmenu  newuser  readopt  register  roomaccess  unlisted; do
115                 ucf "/usr/share/doc/citadel-server/examples/messages/$i" "/var/lib/citadel/messages/$i"
116
117         done
118
119         chown -R citadel:citadel /var/lib/citadel /var/run/citadel /var/spool/citadel
120
121     ### We could also do this on the fly. The following is from Tore
122     ### Anderson:
123     
124     #. /usr/share/debconf/confmodule
125
126     ### find out what the user answered.
127     #  db_get foo/run_on_boot
128     #  run_on_boot=$RET
129     #  db_stop
130
131     ### safely create a temporary file to generate our suggested
132     ### configuration file.
133     #    tempfile=`tempfile`
134     #    cat << _eof > $tempfile
135     ### Configuration file for Foo.
136
137     ### this was answered by you, the user in a debconf dialogue
138     #  RUNONBOOT=$run_on_boot
139
140     ### this was not, as it has a sane default value.
141     #  COLOUROFSKY=blue
142
143     #_eof
144
145     ### Note that some versions of debconf do not release stdin, so
146     ### the following invocation of ucf may not work, since the stdin
147     ### is never coneected to ucfr.
148
149     ### now, invoke ucf, which will take care of the rest, and ask
150     ### the user if he wants to update his file, if it is modified.
151     #ucf $tempfile /etc/foo.conf
152
153     ### done! now we'll just clear up our cruft.
154     #rm -f $tempfile
155
156         db_get citadel/Administrator && admin="$RET"
157         db_get citadel/ServerIPAddress && ip_addr="$RET"
158         echo "applying your settings."
159         echo "/usr/sbin
160 $admin
161 citadel
162 $ip_addr
163
164 " | \
165         /usr/lib/citadel-server/setup -q
166
167     #### There are three sub-cases:
168     ###if test "${2+set}" != set; then
169     ###  # We're being installed by an ancient dpkg which doesn't remember
170     ###  # which version was most recently configured, or even whether
171     ###  # there is a most recently configured version.
172     ###  :
173         ###
174     ###elif test -z "$2" -o "$2" = "<unknown>"; then
175     ###  # The package has not ever been configured on this system, or was
176     ###  # purged since it was last configured.
177     ###  :
178         ###
179     ###else
180     ###  # Version $2 is the most recently configured version of this
181     ###  # package.
182     ###  :
183         ###
184     ###fi 
185         ;;
186   abort-upgrade)
187     # Back out of an attempt to upgrade this package FROM THIS VERSION
188     # to version $2.  Undo the effects of "prerm upgrade $2".
189     #:
190
191     ;;
192   abort-remove)
193     ###if test "$2" != in-favour; then
194     ###  echo "$0: undocumented call to \`postinst $*'" 1>&2
195     ###  exit 0
196     ###fi
197     #### Back out of an attempt to remove this package, which was due to
198     #### a conflict with package $3 (version $4).  Undo the effects of
199     #### "prerm remove in-favour $3 $4".
200     ###:
201
202     ;;
203   abort-deconfigure)
204     ###if test "$2" != in-favour -o "$5" != removing; then
205     ###  echo "$0: undocumented call to \`postinst $*'" 1>&2
206     ###  exit 0
207     ###fi
208     #### Back out of an attempt to deconfigure this package, which was
209     #### due to package $6 (version $7) which we depend on being removed
210     #### to make way for package $3 (version $4).  Undo the effects of
211     #### "prerm deconfigure in-favour $3 $4 removing $6 $7".
212     ###:
213
214     ;;
215   *) echo "$0: didn't understand being called with \`$1'" 1>&2
216      exit 0;;
217 esac
218
219 exit 0