* add a script that tries to migrate the systems /etc/aliases file if existant.
[citadel.git] / citadel / debian / citadel-server.postinst
1 #!/bin/sh
2 # postinst script for citadel-server
3
4 set -e
5
6 # source debconf stuff
7 . /usr/share/debconf/confmodule
8 db_version 2.0
9
10 # glitch: this mustn't be in /var/run/
11 if test -f /var/run/refcount_adjustments.dat; then
12     mv /var/run/refcount_adjustments.dat /etc/citadel/
13 fi
14 case "$1" in
15     configure)
16         chown -R citadel:citadel /etc/citadel
17         chown -R citadel:citadel /var/lib/citadel /var/spool/citadel
18
19         db_get citadel/Administrator && admin="$RET"
20         db_get citadel/ServerIPAddress && ip_addr="$RET"
21         db_get citadel/LoginType && deb_enable_unix_auth="$RET"
22
23         if test "$deb_enable_unix_auth" = "true"; then
24             export ENABLE_UNIX_AUTH=yes
25         else
26             export ENABLE_UNIX_AUTH=no
27         fi
28
29         export IP_ADDR=$ip_addr
30         export CITADEL=''
31         export CITADEL_PORT=504
32         export CITADEL_INSTALLER=yes
33         export CITADEL_UID=`grep citadel /etc/passwd | cut -d :  -f 3`
34         export ACT_AS_MTA=no
35         export SYSADMIN_NAME=$admin
36         export CREATE_XINETD_ENTRY=no
37         export CREATE_INITTAB_ENTRY=no
38         export NO_INIT_SCRIPTS=yes
39 set >/tmp/citsetup
40         echo "applying your settings."
41         /usr/lib/citadel-server/setup -q
42
43         # we're in a fresh install, so we send the welcome message.
44         if test -z "$2"; then
45             export SEPERATOR=2600908b3f21ae7f692b973ed26e212d
46             export WELCOMEHTML=/usr/share/doc/citadel-server/welcomemail.html
47             export WELCOMETXT=/usr/share/doc/citadel-server/welcomemail.txt
48             export FROM=room_citadel_stats@uncensored.citadel.org
49             export TO=room_lobby
50             (
51                 printf "MIME-Version: 1.0\r\nContent-Type: multipart/alternative; \r\n boundary=$SEPERATOR\r\n\r\nThis is a multi-part message in MIME format.\r\n\r\n--$SEPERATOR\r\nContent-Type: text/plain; charset=utf-8\r\nContent-Transfer-Encoding: quoted-printable\r\n\r\n"; 
52                 cat $WELCOMETXT
53                 printf "\r\n\r\n--$SEPERATOR\r\nContent-Type: text/html; charset=US-ASCII\r\nContent-Transfer-Encoding: quoted-printable\r\n\r\n"
54                 cat $WELCOMEHTML; 
55                 printf "\r\n\r\n--$SEPERATOR--\r\n\r\n") | \
56                     /usr/sbin/citmail -bm -r "$FROM" "$TO"
57             /usr/lib/citadel-server/migrate_aliases.sh
58         fi
59
60         if test -S /var/run/citadel/citadel.socket; then 
61             /usr/sbin/sendcommand "DOWN"
62         fi
63
64         while test -S /var/run/citadel/citadel.socket; do 
65             sleep 1
66         done
67
68         db_stop
69     ;;
70
71     abort-upgrade|abort-remove|abort-deconfigure)
72     ;;
73
74     *)
75         echo "postinst called with unknown argument \`$1'" >&2
76         exit 1
77     ;;
78 esac
79
80 #DEBHELPER#
81
82 exit 0